"Software Update Required"

Product Manager
Viewing 15 replies - 46 through 60 (of 76 total)
  • Scott
    Moderator

    Hi,

    I’m having the same issue. All updates are completed and EZX2 is saying “up-to-date” and “ready to use” in the TPM.

    I get the “you need to update your toontrack drum sampler to the latest version before you can install this product” message but EZX2 is all up-to-date. The new expansion pack is downloaded but won’t install.

     

    can you help?

    regards.

    Operating system: macOS Catalina (10.15)

    What does EZD2 show in the details in Product Manager? What version is showing as installed?

    Scott Sibley - Toontrack
    Technical Advisor

    Jamie sefton
    Participant

    Hi Scott,

    Thanks for the quick reply.

    It says 2.1.8 “*partially installed” – AAX not installed.

     

    I’ve tried downloading and re-installing twice. Still does the same.

     

    thanks


    Operating system: macOS Catalina (10.15)
    Jamie sefton
    Participant

    Hi Scott,

    Still unable to download the newly purchased EZX pack. Has there been a fix for this issue?

    kind regards,

    j


    Operating system: macOS Catalina (10.15)
    Scott
    Moderator

    Hi Scott,

    Still unable to download the newly purchased EZX pack. Has there been a fix for this issue?

    kind regards,

    j

    Operating system: macOS Catalina (10.15)

    The latest version if EZD2 is 2.2.1 so I’m not sure why Product Manager isn’t showing an update available if you’re running 2.1.8.

    Not being a Mac guy, the next step would be to open a support ticket with Toontrack directly via the Contact Support button in the FAQ below. I’m sorry I don’t have a better solution at this point.

    https://www.toontrack.com/faq/how-do-i-contact-support/

    Scott Sibley - Toontrack
    Technical Advisor

    1

    Thanked by: Jamie sefton
    Kevin Saaid
    Participant

    Reading the resolution and jaja What garbage customer service do not solve anything disgusting

    • This post was modified 1 year, 3 months ago by Kevin Saaid.
    meyer_92
    Participant

    i´m experiencing the same issue when installing the library content of my sd3 purchase


    Operating system: macOS Big Sur (11)
    Moritz Fischer
    Participant

    I have a similar problem here, Win 10 PC, when trying to load a EZ axpansion in my SD3, it says I need to update the EZ Expansion in the toontrack app, but in the app it says its all up to date.

    Currently 4 out of 6 are not usable at all.

    The SD3 libraries all work as supposed to.


    Operating system: Windows 10
    Olof
    Moderator

    I have a similar problem here, Win 10 PC, when trying to load a EZ axpansion in my SD3, it says I need to update the EZ Expansion in the toontrack app, but in the app it says its all up to date.

    Currently 4 out of 6 are not usable at all.

    The SD3 libraries all work as supposed to.

    Operating system: Windows 10

    In that case, for each of those EZXs, click Show Details in Product Manager, download the full installer for the EZX, uninstall it using the menu to the right, then install it again.

    Olof Hermansson - Toontrack
    Coder

    secondbreakfast
    Participant

    Essentially what’s happening, to anyone who’s confused is Toontrack has gone to such great lengths to deter piracy that they’ve made their entire ecosystem into one big convoluted mess. Whether it’s a lack of information to end users, or complete software incompatibilities between products under the same banner and or versions. Rest assured, the Toontrack Product Manager is an incoherent mess of software that exists solely to make sure you aren’t pirating their software. They could truly care less about whether you just paid them for a product or whatever problems you may be facing due to their lack of competency. For example, I just downloaded a midi pack who’s installer isn’t compatible with Big Sur, I had to manually figure out how to dispatch all the correct files in the right directories to get Superior Drummer to recognize them. But had I not known how to do that (they DON’T offer instructions on how to manually install), I’d be out $23, which is more than likely the case with most people facing similar problems. My recommendation at this point to anyone who either has or hasn’t invested themselves into Toontrack’s ecosystem is to find an alternative to their products and save yourself the money, time, and stress. You can thank me later. To date, superior drummer and all of toontrack’s ecosystem is one of the worst financial decisions I’ve ever made in my life.


    Operating system: macOS Big Sur (11)

    2

    Thanked by: tumbolia and Moritz Fischer
    Moritz Fischer
    Participant

    I have a similar problem here, Win 10 PC, when trying to load a EZ axpansion in my SD3, it says I need to update the EZ Expansion in the toontrack app, but in the app it says its all up to date.

    Currently 4 out of 6 are not usable at all.

    The SD3 libraries all work as supposed to.

    Operating system: Windows 10

    In that case, for each of those EZXs, click Show Details in Product Manager, download the full installer for the EZX, uninstall it using the menu to the right, then install it again.

    I tried that, doesnt work.

    Same error message.

    I downloaded it, unistalled the version, reinstalled, did the updates as it asked me and back to square one.

    Is it because of the updates or whats the problem here?

    Olof
    Moderator

    I have a similar problem here, Win 10 PC, when trying to load a EZ axpansion in my SD3, it says I need to update the EZ Expansion in the toontrack app, but in the app it says its all up to date.

    Currently 4 out of 6 are not usable at all.

    The SD3 libraries all work as supposed to.

    Operating system: Windows 10

    In that case, for each of those EZXs, click Show Details in Product Manager, download the full installer for the EZX, uninstall it using the menu to the right, then install it again.

    I tried that, doesnt work.

    Same error message.

    I downloaded it, unistalled the version, reinstalled, did the updates as it asked me and back to square one.

    Is it because of the updates or whats the problem here?

    That’s odd… Uninstall one again, then start SD3 and check if it really is gone from there.

    Olof Hermansson - Toontrack
    Coder

    Moritz Fischer
    Participant

    I´ve reinstalled it many times, tried without updating it, with updating it.

    Still same problems on all EZ products.

    Right now, I cant use any of my EZ libraries anymore.

    So what do I have to do to actually get some support?

     


    Operating system: Windows 10
    Olof
    Moderator
    insurrectioncan
    Participant

    hello,

    just bought EZD2 and DKFH as well as some other stuff

     

    I installed the 64 bit version of EZD2, updated it,  and all, then DKFH, etc, but the sound library update is giving me the error “one or more required files are missing” even though eveything seems to be installed properly in the product manager ?

    Olof
    Moderator

    hello,

    just bought EZD2 and DKFH as well as some other stuff

     

    I installed the 64 bit version of EZD2, updated it,  and all, then DKFH, etc, but the sound library update is giving me the error “one or more required files are missing” even though eveything seems to be installed properly in the product manager ?

    It looks like you somehow had DFH installed from earlier. See this thread for solution: https://www.toontrack.com/forums/topic/update-installation-issues/

    Olof Hermansson - Toontrack
    Coder

Viewing 15 replies - 46 through 60 (of 76 total)

Please log in to read and reply to this topic.

×