"Software Update Required"

Product Manager
Viewing 15 replies - 31 through 45 (of 76 total)
  • Bigpete 2
    Participant

    I just purchased the EZdrummer-Reggae, I downloaded the software but when trying to install I get an error saying “You need to upgrade your Toontrack software to the latest version before you can install this product” I only just bought the software, and downloaded it. Help!


    Operating system: Windows 10
    Scott
    Moderator

    I just purchased the EZdrummer-Reggae, I downloaded the software but when trying to install I get an error saying “You need to upgrade your Toontrack software to the latest version before you can install this product” I only just bought the software, and downloaded it. Help!

    Operating system: Windows 10

    EZXs are expansion packs that require a sampler to work. You need either EZD2 or S3 to load the expansion in.

    Scott Sibley - Toontrack
    Technical Advisor

    Mikelangelo
    Participant

    Hi! How can I update Toontrack software? I tried to install “Made Of Metal EZX” and when I press “install” it slags me off saying: You need to upgrade your Toontrack software to the latest version before you can install this product.

    So, how do I update my Toontrack software in order to install the program? Other option is of course to ask refund, but…


    Operating system: Windows 10
    Scott
    Moderator

    Hi! How can I update Toontrack software? I tried to install “Made Of Metal EZX” and when I press “install” it slags me off saying: You need to upgrade your Toontrack software to the latest version before you can install this product.

    So, how do I update my Toontrack software in order to install the program? Other option is of course to ask refund, but…

    Operating system: Windows 10

    EZXs are expansion packs that require a sampler to work. You need either EZD2 or S3 to load the expansion in.

    Scott Sibley - Toontrack
    Technical Advisor

    Mikelangelo
    Participant

    Right. Then where do I get EZD2 or S3? And does it mean that I have to purchase them for the product I already purchased? Basicly; am I just wasting my money and not getting any working product here…?

    Scott
    Moderator

    Right. Then where do I get EZD2 or S3? And does it mean that I have to purchase them for the product I already purchased? Basicly; am I just wasting my money and not getting any working product here…?

    Yes, EZD2 or S3 are separate products that would need to be purchased.

    If you don’t have the full sampler, having just the EZX expansion is a waste of money yes.

    Scott Sibley - Toontrack
    Technical Advisor

    duotone_
    Participant

    Am having problems accessing the Toontrack Product Manager today also, it was working OK 2 weeks ago, when I last used it to register some products.

    When I click ‘Retry’ I get the same message

    ‘UPDATE PRODUCT MANAGER

    Update check failed.

    Connection could not be established.’


    Operating system: Windows 8.1
    Patrick Doninger
    Participant

    I have the same problem as duotone_ right now.

    Dawson87
    Participant

    I am having the same problem. Says update needed to proceed, yet I just downloaded it. I need to know how to fix it and how to be able to download it. Not what needs downloaded.


    Operating system: Windows 10
    Olof
    Moderator

    I am having the same problem. Says update needed to proceed, yet I just downloaded it. I need to know how to fix it and how to be able to download it. Not what needs downloaded.

    Operating system: Windows 10

    It can be a misleading message because sometimes it means that none of the required products (samplers) is installed. Nashville EZX requires (like its product page says): “a working EZdrummer 1.4 (or above) or a Superior Drummer 2.3 (or above) installation.”

    Olof Hermansson - Toontrack
    Coder

    Aaron Cline
    Participant

    Hello,

    I have a registered copy of SD2 with the latest update (2.4.4) I bought an EZX expansion (Pop Punk)

    I have checked everything and I get the Software Update is Required message. I do own a registered copy of Superior Drummer 2.

    Is there anything I’m missing? SD2 works fine in Pro Tools.

    ((Mac 10.13.6))


    Operating system: macOS High Sierra (10.13)
    Scott
    Moderator

    Hello,

    I have a registered copy of SD2 with the latest update (2.4.4) I bought an EZX expansion (Pop Punk)

    I have checked everything and I get the Software Update is Required message. I do own a registered copy of Superior Drummer 2.

    Is there anything I’m missing? SD2 works fine in Pro Tools.

    ((Mac 10.13.6))

    Operating system: macOS High Sierra (10.13)

    That EZX requires EZD2 or S3
    SYSTEM REQUIREMENTS.
    3 GB free disk space, 2 GB RAM (4 GB recommended).

    A working EZdrummer 2.1.8 or Superior Drummer 3.1.2 (or above) installation.

    Scott Sibley - Toontrack
    Technical Advisor

    1

    Thanked by: Aaron Cline
    Aaron Cline
    Participant

    Awesome. So if I purchase the crossgrade to SD3, it can run the EZX expansion kits?

    If so, that’s what I’ll do.


    Operating system: macOS High Sierra (10.13)
    Scott
    Moderator

    Awesome. So if I purchase the crossgrade to SD3, it can run the EZX expansion kits?

    If so, that’s what I’ll do.

    Operating system: macOS High Sierra (10.13)

    There is no longer an S2 to S3 upgrade option anymore. The cheapest way would be to purchase EZD2 which I’ve seen at $149 at places like Sweetwater. Plus, a free EZX with that purchase.

    https://www.sweetwater.com/store/detail/EZdrum2–toontrack-ezdrummer-2-download

    Scott Sibley - Toontrack
    Technical Advisor

    1

    Thanked by: Aaron Cline
    Jamie sefton
    Participant

    Hi,

    I’m having the same issue. All updates are completed and EZX2 is saying “up-to-date” and “ready to use” in the TPM.

    I get the “you need to update your toontrack drum sampler to the latest version before you can install this product” message but EZX2 is all up-to-date. The new expansion pack is downloaded but won’t install.

     

    can you help?

    regards.


    Operating system: macOS Catalina (10.15)
Viewing 15 replies - 31 through 45 (of 76 total)

Please log in to read and reply to this topic.

×