"Software Update Required"

Product Manager
Viewing 10 replies - 61 through 70 (of 70 total)
  • EMILSAM VELAZQUEZ
    Participant

    WHE GOING TO INSTALL IT TELLS ME SOFTWARE UPDATE IS REQUIRED. WHAT CAN I DO


    Operating system: macOS Big Sur (11)
    Scott
    Moderator

    WHE GOING TO INSTALL IT TELLS ME SOFTWARE UPDATE IS REQUIRED. WHAT CAN I DO

    Operating system: macOS Big Sur (11)

    What are you trying to install? Looking at your account it looks like you purchased the Hip-Hop EZX that requires EZD2 and you have EZD1. Is this the problem?

    Scott Sibley - Toontrack
    Technical Advisor

    tumbolia
    Participant

    Jumping on this thread…seems like a right of passage! Hah.

    Scenario:
    MacOS Monterey, plenty of drive space available
    Purchased EZD2 a while back and got Pop Punk EZX. Has worked fine.

    Last night I purchased EZX’s: Electronic Edge, Singer Songwriter, and The Blues. The Blues installed clean and works. The other two give me the “…upgrade your sampler” error.

    What I have done so far (all have failed):
    1. Tried installing failed  EZX’s manually
    2. Uninstalled EZD2, rebooted, reinstalled EZD2, rebooted, updated EZD2 with available updates, tested the Blues – still worked
    3. Tried to download an install failing EZXs, same error.
    4. Tried to install EZX’s manually, same error.

    EZD2 Installation Info

    Now what? I’m about ay my limit with trying to get this working before going into refund mode.


    Operating system: macOS Monterey (12)
    John
    Moderator

    Hi tumbolia,

    I presume you are using the Product Manager to download and install the EZX:s, right?

    Could you please post a screen shot of the failing installation?

    BR,
    John

    John Rammelt - Toontrack
    Technical Advisor

    tumbolia
    Participant

    Yeah, doing everything through PM. Only tried the manual step of installing the EZX’s from their downloads after PM was giving the error and after re-installing EZD2 through PM. I also read every single post in this thread checking all the previously mentioned fixes.

    UPDATE:
    So last night I uninstalled/installed EZD2 again through PM and rebooted. I DID NOT do any EZD2 updates. I tried installing the EZX’s manually on the older version of EZD2 (knowing that would prob not work) to see if the error language would change. It didn’t. so I let it sit overnight.

    I get your reply (thanks for the quick reply!) and sit down at my Mac and install the three avail updates for EZD2 (core to 1.2.2, midi library, and sound library). Then I went to install the EZX’s to get the screenshots and presto/wtf – both EZX’s install cleanly.  No idea why. The only thing I did different after my 4 hours of working on this was let the old version of EZD2 sit overnight. Sounds silly I know.  Did you do anything on the account on your end (I know that also sounds silly).

    John
    Moderator

    Hi,

    I did nothing but I’m glad to hear you’re sorted now.

    BR,
    John

    John Rammelt - Toontrack
    Technical Advisor

    Rick McKay
    Participant

    I’m not having any issues myself but, a friend of mine, who I recommended Toontrack products to, is. He’s bought EZMix2, download and installed it, installed Mastering I and II, but is being told that he needs to update EZMix2 before he can use them. He’s ALREADY got the latest version. He uninstalled and reinstalled, but gets the same message.
    Why are people suddenly having these issues. Toontrack MUST address this. I feel bad for recommending this to him now.


    Operating system: macOS Big Sur (11)
    Olof
    Moderator

    I’m not having any issues myself but, a friend of mine, who I recommended Toontrack products to, is. He’s bought EZMix2, download and installed it, installed Mastering I and II, but is being told that he needs to update EZMix2 before he can use them. He’s ALREADY got the latest version. He uninstalled and reinstalled, but gets the same message.
    Why are people suddenly having these issues. Toontrack MUST address this. I feel bad for recommending this to him now.

    Operating system: macOS Big Sur (11)

    EZmix 2.0.9 or higher is required to install those packs. You say he installed them and is then being told that he needs to update EZmix 2? Is it EZmix 2 plug-in that is saying that? If so, what is the version of that plug-in?

    Olof Hermansson - Toontrack
    Coder

    Andy219
    Participant

    So are you saying that you have to have the full EZ drummer software instead of one part of it like EZXMetal?

    Scott
    Moderator

    So are you saying that you have to have the full EZ drummer software instead of one part of it like EZXMetal?

    EZdrummer expansion packs (EZXs) require the full EZdrummer product yes.

    Scott Sibley - Toontrack
    Technical Advisor

Viewing 10 replies - 61 through 70 (of 70 total)

Please log in to read and reply to this topic.

×