"Software Update Required"

Product Manager
Viewing 15 replies - 1 through 15 (of 76 total)
  • Scott
    Moderator

    All EZX expansion packs require the full EZD2 or S3 sampler to load into. The error indicates you don’t have either registered to your account.

    Scott Sibley - Toontrack
    Technical Advisor

    tyguy205
    Participant

    What does that mean? I have the exact same problem! Why did we make a toontrack track account? Just for you to tell us we don’t have it registered? Get it together toon track. I just bought something I can’t use…

    3

    Thanked by: deloyisme, emiemi and ali_mahmoud3_1
    Scott
    Moderator

    What does that mean? I have the exact same problem! Why did we make a toontrack track account? Just for you to tell us we don’t have it registered? Get it together toon track. I just bought something I can’t use…

    As described on every EZX product page…

    “SYSTEM REQUIREMENTS.
    1 GB of free hard disk space, 1 GB RAM.

    A working EZdrummer 1.4 (or above) or a Superior Drummer 2.3 (or above) installation.”

    Which Toontrack sampler do you have to run the DFH EZX expansion pack? EZD 1.4 (or above) or S2.3 (or above)?

    Scott Sibley - Toontrack
    Technical Advisor

    tyguy205
    Participant

    I just want my $84.73 back. This has happened to enough people that its a problem.

    Scott
    Moderator

    I just want my $84.73 back. This has happened to enough people that its a problem.

    Please contact Toontrack Support directly via the Contact Support button in the FAQ below to request a refund.

    How do I contact support?

    Scott Sibley - Toontrack
    Technical Advisor

    2

    Thanked by: Paul Seaman and fatibof18
    gmusicthegenerator
    Participant

    hello,

    can you provide the links to download to fix problem.

    Scott
    Moderator

    hello,

    can you provide the links to download to fix problem.

    Can you provide some details about your problem? The above users purchased MIDI packs without having purchased a compatible Toontrack sampler. You seem to have an EZkeys Sound Library and EZmix2. If your EZkeys MIDI pack isn’t installing, we’ll need more info or, at least, a pic of the exact error message you are getting.

    Scott Sibley - Toontrack
    Technical Advisor

    skmusic84
    Participant

    I’m having the same problem – I am prompted to get a software update when I try to install the new John Feldman Pop Punk pack. I have Superior Drummer 2.4.4 downloaded and installed and all my other packs have worked fine. I have 166.99 GB of available space on my computer. Every product I need to use this is listed as ready to use in my Toon Track Product Manager. Yet, even after installing and reinstalling the product manager, I am told with each attempt to install the new pack that I need a software update.

    Scott
    Moderator

    I’m having the same problem – I am prompted to get a software update when I try to install the new John Feldman Pop Punk pack. I have Superior Drummer 2.4.4 downloaded and installed and all my other packs have worked fine. I have 166.99 GB of available space on my computer. Every product I need to use this is listed as ready to use in my Toon Track Product Manager. Yet, even after installing and reinstalling the product manager, I am told with each attempt to install the new pack that I need a software update.

    The system requirements for that EZX is:

    A working EZdrummer 2.1.8 or Superior Drummer 3.1.2 (or above) installation.

    Scott Sibley - Toontrack
    Technical Advisor

    Taylor Clark
    Participant

    Im having the same issue. I use Toontrack all the time, have EZ Drummer 2, etc. My product manager says all my stuff is updated (including downloading the latest version of PM). I just bought the Dream Pop drum add on–and every time I go to install it within the PM it says i need to upgrade to the latest PM! Makes no sense. Ive uninstalled/reinstalled several times. What gives?!

    • This post was modified 3 years, 7 months ago by Taylor Clark.
    Olof
    Moderator

    I just bought the Dream Pop drum add on–and every time I go to install it within the PM it says i need to upgrade to the latest PM!

    Not quite – the EZX installer, which PM launches, just says that a software update is required. What it refers to is EZdrummer or Superior Drummer. In your case this will probably be resolved if you install the EZdrummer 2.1.8 update again. You can download and install it from the Details view for EZdrummer 2 in PM.

    Olof Hermansson - Toontrack
    Coder

    Anonymous
    Inactive

    I have SD3 installed and I am also having this issue installing my EZdrummer add ons. I have several EZdrummer packs that I can’t instal that say software update required. Either fix this, or give me cakewalked my 600$ in just the expansion packs alone! I was told that I do not need EZdrummer if I had SD3 and Sd3 runs the expansions.

    Mac OSX 10.14.4

    • The post has been modified 2 times, last modified 3 years, 7 months ago by .
    Henrik
    Participant

    I have SD3 installed and I am also having this issue installing my EZdrummer add ons.

    Have you updated to the latest software version of Superior Drummer 3?
    If you haven’t, please do.
    If you have, please re-install the software update.

    Henrik Ekblom - User Experience Designer
    Toontrack

    Olof
    Moderator

    I have SD3 installed and I am also having this issue installing my EZdrummer add ons. I have several EZdrummer packs that I can’t instal that say software update required. Either fix this, or give me cakewalked my 600$ in just the expansion packs alone! I was told that I do not need EZdrummer if I had SD3 and Sd3 runs the expansions. Mac OSX 10.14.4

    Paul,

    Please open Applications > Utilities > Terminal and paste the following commands there (the entire block of text at once):

    /usr/libexec/PlistBuddy -c "Delete :SDIVersion" /Users/Shared/Toontrack/Preferences/com.toontrack.superior.superior2.plist
    /usr/libexec/PlistBuddy -c "Add :SDIVersion string 2.5" /Users/Shared/Toontrack/Preferences/com.toontrack.superior.superior2.plist
    echo

    That should fix it. The SD 3.1.3 installer was supposed to do this but doesn’t because of a bug.

    Note to others: These commands should only be used if you have installed Superior Drummer 3 on your Mac.

    Olof Hermansson - Toontrack
    Coder

    3

    Thanked by: WeegeeNoir, Josh and Henrik
    beanland
    Participant

    Not sure if this is the same issue described above…

    Ran Product Manager, and it tells me I need to update. However, I get a permission error as shown in the attached image.

Viewing 15 replies - 1 through 15 (of 76 total)

Please log in to read and reply to this topic.

×