You need to upgrade your Toontrack software to the latest version before you can install this product.

EZdrummer Pre-sales
Viewing 15 replies - 1 through 15 (of 55 total)
  • ScottScott
    Moderator
    strato92
    Participant

    i got the same with “Made of Metal”, what can here help ?

    ScottScott
    Moderator

    @strato92 said:

    i got the same with “Made of Metal”, what can here help ?

    The only product you have registered to your account is the EZdrummer 2 demo. You need the full version to run EZXs. Not to mention a legit version of the Made of Metal…or one registered to your account at least.

    Scott Sibley - Toontrack
    Technical Advisor

    Willie Boswell
    Participant

    @Scott said:

    @strato92 said:

    i got the same with “Made of Metal”, what can here help ?

    The only product you have registered to your account is the EZdrummer 2 demo. You need the full version to run EZXs. Not to mention a legit version of the Made of Metal…or one registered to your account at least.

    I have recently purchased the HipHop Edition Bundle so I have the full version but I’m getting the exact same message. I’ve registered it to the account too. The Jazz EZX loaded with no problem but not the hiphop. Kinda frustrated right now to be honestYell

    1

    Thanked by: DSfear
    ScottScott
    Moderator

    What version number is showing on your EZD 2 interface? The latest version of EZD2 is required to use the Hip-hop EZX. It is version 2.1.1.

    Scott Sibley - Toontrack
    Technical Advisor

    Willie Boswell
    Participant

    @Scott said:

    What version number is showing on your EZD 2 interface? The latest version of EZD2 is required to use the Hip-hop EZX. It is version 2.1.1.

    This is what shows under “Menu/About EZDrummer”

    EZdrummer plug-in version 2.1.1 (build 10513) [64-bit VST]
    Standalone host version 2.1.1 (build 10513)

    SOUND LIBRARIES
    EZdrummer 2 Modern version 1.0.2
    EZdrummer 2 Vintage version 1.0.2
    Jazz version 1.5.1

    MIDI LIBRARIES
    EZdrummer 2 Modern/Vintage version 1.0.1
    EZdrummer 2 Percussion version 1.0.1
    EZX Jazz version 1.5.0
    Monster MIDI Fills Pack 2 version 1.0.0

    JohnJohn
    Moderator

    @illasacks:

    Could you please try re-downloading and re-installing the 2.1.1 update before trying with the Hip-Hop! again and report back?

    John Rammelt - Toontrack
    Technical Advisor

    Willie Boswell
    Participant

    Ok it works now. I had to re-install the update for the drummer, restart and the install the ezx. That got it going. Thanks

    Arthur Cristian
    Participant

    We also have the same issue with Hip Hop.

    We performed the updater to the latest version 2.1.1 but EZ Drummerr 2 standalone still only shows version 2.0….
    We tried installing 2.1.1 twice.with no success.

    We use Windows 7 Home Professional 64 bit

    Even after doing a reboot the version is still 2.0……

    We installed a new c: drive (Samsung SSD 850 EVO 1T) so we are reinstalling everything from scratch.
    We have around 22 EZX’s to reinstall.
    Starting from the top of our products, so far we’ve installed Americana, Claustrophobic, Drum Kit From Hell, Electronic, Funkmasters without any issues but Hip Hop won’t install.

    We’ve had no problems installing EZKeys and the 9 pianos, keyboards, organs, etc, we’ve got.
    We also installed EZ Mix with no issues either.
    We still have Superior Drummer 2 to install and we have all the SDX’s and most Producer presets to install.

    With EZ Drummer, this was how we started a few years ago…..
    Ez Drummer Lite — > EZ Drummer Lite Upgrade — > EZ Drummer — > EZ Drummer 2 Upgrade
    After installing the new C: drive we ONLY installed EZ Drummer 2 from the EZ Drummer 2 Upgrade folder.
    We are only performing all tests in standalone mode – EZ Drummer 2 works in our DAW as a VST – our DAW is Studio One Pro 2.6.5

    Where too from here?

    Arthur Cristian
    Participant

    We’ve now installed EZX Indie Folk, Jazz, Latin Percussion & Made Of Metal and we’ve tried re-downloading and reinstalling the EZdrummer Update 2.1.1. The EZdrummer stand-alone still says version 2.0.2 (64 bit) is installed and we now get an extra error message….. “One or more Midi packs require a later version of EZdrummer to work properly. Please login and download the latest version at http://www.toontrack.com“.

    ?????

    JohnJohn
    Moderator

    @LoveForLife:
    Please start a new topic in the EZdrummer Help section for registered users. Since this is the Pre-sales section, it isn’t monitored for Support matters.
    http://www.toontrack.com/forum/ezdrummer-help/

    John Rammelt - Toontrack
    Technical Advisor

    Daniel Gordon
    Participant

    Hi i have download the EZX hiphop add on, and it comes up with message saying i need to update toontrack software. What do i do now? I have Superior Drummer 2.4.0 64 bit. As it says that is required. Thanks

    JohnJohn
    Moderator

    Please download and install the latest Superior 2 update (currently 2.4.3)..

    John Rammelt - Toontrack
    Technical Advisor

    corneill briss
    Participant

    HI i have purchase ezdrummer2 on your website then i download and install it on my mac everything is good.then i purchase hiphop ezx when i try to install it i have the message that i need to upgrade to the latest version.how can i do to install it?

    ScottScott
    Moderator

    @blond1_1 said:

    HI i have purchase ezdrummer2 on your website then i download and install it on my mac everything is good.then i purchase hiphop ezx when i try to install it i have the message that i need to upgrade to the latest version.how can i do to install it?

    Download and install the latest version of EZD2 from your Toontrack account. It is in the Updates tab under your EZD2 product.

    Scott Sibley - Toontrack
    Technical Advisor

Viewing 15 replies - 1 through 15 (of 55 total)

Please log in to read and reply to this topic.

×