icon-aiicon-arrangementsicon-arrow-left-1icon-arrow-left-2icon-arrow-left-3icon-arrow-right-1icon-arrow-right-2icon-arrow-right-3icon-automationicon-bleedicon-bounceicon-brushesicon-brushes2icon-campaign-pageicon-circlesicon-cloudCommentsicon-cross-invicon-crossicon-cymbalicon-dislike-1icon-dislike-2Unread topicicon-downloaddrumsicon-drag-dropicon-drumkiticon-drums2icon-drumsticksicon-edrumsicon-electronicTopicicon-envelopeicon-fadersicon-faqForumForumTopic replyicon-futurehiticon-galaxyicon-grid-editoricon-headphonesicon-hihaticon-hot-topicicon-importsamplesicon-information-invicon-informationicon-joystickicon-kickicon-like-1icon-like-2Locked topicicon-macrosicon-massenburgicon-microphoneicon-midi-exporticon-midi-searchicon-midi-trackericon-midi-tracksicon-midiicon-mix-channelsicon-mixericon-news-inspirationicon-one-noteicon-percussionicon-percussion2Sticky topicicon-play-1-invicon-play-1icon-play-2-invicon-play-2icon-play-3icon-plus-invicon-plusicon-presetsPrivate topicicon-rawicon-reverseanythingicon-samplesicon-save-drumicon-seamlessicon-settingsicon-shapesicon-snareicon-song-tracksicon-ssdicon-stackicon-tap2findicon-tempoicon-third-partyicon-three-notesicon-tomTopic with best answericon-two-notesicon-usericon-videoicon-workflow

SD3 hi hat settings

Requests and Feedback
Viewing 15 replies - 1 through 15 (of 33 total)
  • olliepudge
    Participant

    Sorry. Forgot to add that I’m using the Roland TD-25 module.

    Damian BluntDamian Blunt
    Moderator

    Hi,

    Go to settings > MIDI in/E-drums > Select the ‘Roland’ preset from the dropdown > ‘Edit MIDI Mapping and Response’ pane > select the ‘Hi-hat and Snare CC’ > Hi-hat Pedal Control and adjust the openness settings from there. Once you have achieved your desired response you can save your own MIDI mapping preset which will be loaded at startup (if required).

    When changing libraries you may have to adjust the curve again as different libraries have different amounts of open articulations.

    Hope this helps

    Damian Blunt - Toontrack
    Quality Assurance
    Betatesting

    olliepudge
    Participant

    Hi Damian,
    Yes I tried that. I have it set to the closed setting, but it still sounds a little open. Doesn’t close tight. It seems like adjusting ANY of the articulations does nothing as if the software isn’t reading my hi hat, but that can’t be the case because it plays sound when I hit it. I’m puzzled here.

    HenrikHenrik
    Forum Crew

    Use the MIDI Monitor in e-drum settings page, or the MIDI monitor property box in the Drums tab to find out what CC values your hi-hat sends out when opened vs. when it’s closed. Report it here and we might be able to guide you further!

    Henrik Ekblom - User Experience & Interaction Design
    Toontrack

    olliepudge
    Participant

    Hey guys. I was able to correct this by making some adjustments in the MIDI settings on my drum module. Thanks for the fast responses though! These kits sound killer by the way! It’s insane.

    HenrikHenrik
    Forum Crew

    Nice to hear. Keep on rocking! 🙂

    Henrik Ekblom - User Experience & Interaction Design
    Toontrack

    Hubert Porck
    Participant

    @olliepudge said:
    Hey guys. I was able to correct this by making some adjustments in the MIDI settings on my drum module. Thanks for the fast responses though! These kits sound killer by the way! It’s insane.  

    Hello Ollie,

    I own a TD25 too and have EXACTLY the same problem. Can you tell me how you fixed it??? thanx!!!!!

    Andreas
    Forum Crew

    @olliepudge said:
    It seems like adjusting ANY of the articulations does nothing as if the software isn’t reading my hi hat, but that can’t be the case because it plays sound when I hit it. I’m puzzled here.  

    By ‘adjusting ANY of the articulations …’, do you mean that you are using the Hi-Hat Pedal Control in the Hi-Hat & Snare CC tab in MIDI in/E-Drums Settings? What happens if you make sure the bottom slider (between the Closed and Tight articulations) on that control is set to a really low value, like 2 and all of the other sliders to 0? If this makes it easy to trigger the Tight articulation, can you then tweak all the sliders to make the Hi-Hat respond ok?

    Andreas Walfridsson - Toontrack
    Interaction Designer

    Hubert Porck
    Participant

    Hi guys,

    I jus found a (weird) solution. At the ‘MIDI-in/E-drums’ tab, I chose Roland first, but then the hi hat did NOT trigger well.
    Then……….. I used the ‘GENERIC’ preset, and all works 100% perfect.

    Maybe something for an upcoming update Andreas / Henrik???

    I am a happy customer now 🙂

    HenrikHenrik
    Forum Crew

    @hubert Porck said:
    I jus found a (weird) solution. At the ‘MIDI-in/E-drums’ tab, I chose Roland first, but then the hi hat did NOT trigger well.
    Then……….. I used the ‘GENERIC’ preset, and all works 100% perfect.
     

    Is there a difference for you if you have “Generic” selected vs. if you first select “Roland” then select “Generic” again?

    Henrik Ekblom - User Experience & Interaction Design
    Toontrack

    Hubert Porck
    Participant

    @henrik said:

    @hubert Porck said:
    I jus found a (weird) solution. At the ‘MIDI-in/E-drums’ tab, I chose Roland first, but then the hi hat did NOT trigger well.
    Then……….. I used the ‘GENERIC’ preset, and all works 100% perfect.
     

    Is there a difference for you if you have “Generic” selected vs. if you first select “Roland” then select “Generic” again?  

    Sorry, I don’t understand what you mean. I started with Roland, then I switched to Generic, and it all works 100% superb.

    HenrikHenrik
    Forum Crew

    What I meant was to try to figure out if there’s a difference depending on what preset you had selected before the current one.

    For example – is there a difference if you select “Yamaha” then “Generic” – in comparison to selecting “Roland” then “Generic”?

    Henrik Ekblom - User Experience & Interaction Design
    Toontrack

    Kim S
    Participant

    SD2 used to work perfect with my Roland VH11 hi-hat however can’t say the same for SD3 unfortunately.

    I read through this thread and tried all of the above suggestions but unfortunately nothing worked and the sliders referred to for hi hat settings to make tighter or more open honestly seem to do nothing at all in SD3.
    The only thing I tried was tweaking my actual VH11 Hi-hat settings through my TD 12 module. Helped a bit but in the end the only way I could get my VH11 to make the closed tip, edge sounds was to change my module setting to VH12, even though I have a VH11.

    Would Toontrack be able to work on the hi-hat settings for edrums/Vdrums in SD3 to be as awesome as they were in SD2?

    Thanks

    KIm

    * A long time user of Superior Drummer SD2 with my TD12 Roland VDrums

    Mark Grace
    Participant

    Yes, I too am having a Hi-Hat issue with my Yamaha DTX 950 kit…

    SD2 seemed to track the CC info much better than SD3.

    I will keep tweaking, and trying the suggestions above, but wanted to put my 2 cents worth in.

    Thank you Toontrack for an otherwise EXCELLENT upgrade!
    MG

    RuffRider
    Participant

    I have a Roland TD-25 set also and I got around the closed hi hat problem by using the “Default” map setting instead of the “Roland” map setting.

Viewing 15 replies - 1 through 15 (of 33 total)
×