MIDI library in Superior 3 missing !?

Superior Drummer 3 Pre-sales
Viewing 15 replies - 1 through 15 (of 32 total)
  • Scott
    Moderator

    It’s a separate download/install. There is a Core MIDI installer under S3 Library Part 1 – Basic Sound Library in Product Manager.

    Scott Sibley - Toontrack
    Technical Advisor

    droogie
    Participant

    Yeah man… I got it. Thanks a lot !

    flashaha007
    Participant

    I have a related question, in that my midi database keeps disappearing most days. I’ll open a project and go to song creator, and tap to find etc and get no results, then I realise my midi database has vanished so I have to go to settings and restore it, then each third party file set (Groove Monkey etc). I have even got an ‘error midi database lost’ or suchlike, and have to rescan again. This is happening most days, sometimes a few times a day. Am guessing a bug that needs fixing? I know how to fix it as in rescan database, but I don’t want to be doing that most sessions! Any thoughts Toontrack Dudes? (Sorry to hijack thread but couldn’t find solution)

    Patrik
    Participant

    @flashaha007 said:
    I have a related question, in that my midi database keeps disappearing most days. I’ll open a project and go to song creator, and tap to find etc and get no results, then I realise my midi database has vanished so I have to go to settings and restore it, then each third party file set (Groove Monkey etc). I have even got an ‘error midi database lost’ or suchlike, and have to rescan again. This is happening most days, sometimes a few times a day. Am guessing a bug that needs fixing? I know how to fix it as in rescan database, but I don’t want to be doing that most sessions! Any thoughts Toontrack Dudes? (Sorry to hijack thread but couldn’t find solution)  

    That sounds very strange indeed and not at all how it should work.
    I need some information to try and understand what could go wrong for you.

    1) What windows version do you use? (I checked your previous posts and gathered you at least run windows and not MAC right?)
    2) What DAW do you use and do you sometimes also use the stand alone application?
    3) Can you see if you have an “errorlog.doc” file in your “C:/ProgramData/Toontrack/Superior3” folder, please post it here if you do. (The “ProgramData” folder is hidden so you might need to enable “Hidden Items” under “View” in File Explorer.
    4) Next time your database vanishes, can you check in C:/Users/”Your user”/AppData/Roaming/Toontrack/Superior3 for a file “MidiDB”, is it there and what size does it have? Also in the same folder there is a “MidiDB-wal” file, what size does that have?

    Sorry for the inconvenience!

    Bass player in swedish thrash metal band Defiatory
    www.defiatory.se

    Coder at Toontrack
    www.toontrack.com

    flashaha007
    Participant

    Hi and sorry for the delay, and I just had to restore database again! I am on Windows 10 64 bit, and use Pro Tools 12.8.2. I don’t use standalone hardly at all.

    I have just checked and found something, an error log where you asked. MidiDB is 87.9kb and MidiDB-wal shows at 0 kb, although this was after I restored the database as hadn’t read your post at that point. I will try next time it happens. Thanks.

    flashaha007
    Participant

    Not sure if this is exactly the same, but this was the next time I had the issue. Everything appears to load up as normal, including 3rd party midi. all available, except when I open SD3 the song creator tab has been minimised, and when I open it it shows as ‘no matches’ in every box, and the same when I drag in any midi pattern. ‘no matches’. It’s then that I have to restore everything again! It happens most days if not more than once a day. I just tried restoring, then closing/saving the session and quitting Pro Tools then relaunching the same session and everything was as it should be so will try and look out for a pattern.

    Thanks in advance for any input.

    Regards,

    Ashley

    flashaha007
    Participant

    Sorry forgot to upload attachments properly, but it was exactly the same size!

    Haim Ari
    Participant

    Hello,
    Same Issue here (screenshot attached)
    Windows 10 64
    Studio One 3.5
    Did anyone managed to solve the issue ?

    sd3.PNG

    Scott
    Moderator

    @Haim Ari said:
    Hello,
    Same Issue here (screenshot attached)
    Windows 10 64
    Studio One 3.5
    Did anyone managed to solve the issue ?

    sd3.PNG  

    Like posted in the second post, the S3 MIDI is a separate download/install. There is a Core MIDI installer under SUPERIOR DRUMMER 3 LIBRARY in Product Manager.

    Have you installed that MIDI?

    Scott Sibley - Toontrack
    Technical Advisor

    achilefu
    Participant

    I have added a midi library but can not play it. Yellow exclamation mark. Please help me fix it. Thanks very much.01-May.-06-16.28.jpg

    John
    Moderator

    @achilefu said:
    I have added a midi library but can not play it. Yellow exclamation mark. Please help me fix it. Thanks very much.<img src="https://www.toontrack.com/app/sp-resources/forum-image-uploads/kho 

    Hi ,

    did you try to Restore the MIDI database in Settings?

    BR,
    John

    John Rammelt - Toontrack
    Technical Advisor

    achilefu
    Participant

    Yes, I try try to Restore the MIDI database in Settings but not work 🙁

    John
    Moderator

    OK,

    what is the error message when you click the exclamation mark?
    Did you try downloading and re-installing the SD3 Core MIDI pack, found under ‘Updates’ for Part1 of the SD3 Core Library?

    BR,
    John

    John Rammelt - Toontrack
    Technical Advisor

    achilefu
    Participant

    Only a few active midi, left clicking on it will yellow triangle error. I have downloaded and reinstalled a lot of times. I attached the image below. 🙂01-May.jpg

    John
    Moderator

    Hi,

    a couple of things I noticed when inspecting your screen shots more closely:

    1) you are running a very old version of Superior Drummer 3

    2) you have a lot of MIDI grooves there from a lot of Toontrack products; SDX:s and MIDI Packs. Yet you have no products registered to your account.
    How is this possible?

    3) they way your MIDI libraries are listed, suggests some kind of tampering, since all MIDI libraries are lumped together instead of listed under different categories.
    How are these installed?

    BR,
    John

    John Rammelt - Toontrack
    Technical Advisor

Viewing 15 replies - 1 through 15 (of 32 total)

Please log in to read and reply to this topic.

×