HiHat foot control

EZdrummer Pre-sales
Viewing 13 replies - 1 through 13 (of 13 total)
  • OlleOlle
    Forum Crew

    Have you enabled one of the e-drum mappings in the top right hand menu?

    Olof Westman - Toontrack
    Coder

    Les Barker
    Participant

    thanks for your reply, yes, i chose ‘other’. I have tried each of them and my kit works the same on each e-drum mapping selections.

    RogueRogue
    Moderator

    according to your module’s MIDI Implementation Chart the DD505 does not send CC04 but CC01 instead (possibly not even tied to the foot controller)… which is highly unexpected. We will look into how we can make this work (or rather why it does not work in the first place)…

    Rogue Marechal - Toontrack
    Configuration Manager

    Les Barker
    Participant

    awesome, thanks for any assistance you can provide, especially during this manic period of a great new release!

    RogueRogue
    Moderator

    well… according to me your hihat pedal does not support continuous controller data but is what we call a ‘foot switch’, only able to transmit an open or closed ‘note’. With such a controller, when you choose one of the e-drum map (‘Other’ for example) you would only be able to trigger the fully open sound. Is that what you are experiencing?

    … anyway, you should check with the manufacturer the nature of your controller as I don’t think is it what would be considered a standard ‘foot controller’.

    Rogue Marechal - Toontrack
    Configuration Manager

    Les Barker
    Participant

    ok, thanks, yes that is what i am experiencing. I only get the fully open sound, however it does choke the hihat after playing an open hihat, it just won’t play a single choked hihat. So this would say it does read the pedal in some manner.

    It works fine for all NI drumkits.

    EDIT: ok, i just opened EZD2 up using Reaper rather than standalone, and it works fine, but still doesn’t work in standalone. No biggie as at least i can now play choked hihat.

    Strange though!Smile

    dmarks
    Participant

    I have EZ Drummer 2 and am trying to record w/ Yamah DTXpRESS IV e-drums with midi using StuioOne Artist 5.  I’ve mapped EZ Drummer to Yamaha drums and after hitting the hi-hat while keeping my foot down on the hi-hat pedal, the hi-hat opens and stays open in EZ Drummer/DAW.  Changing the Pedal Correction doesn’t solve the issue.  How do I fix this so my hi-hat pedal works correctly?

    JohnJohn
    Moderator

    Hi dmarks,

    if you instead open EZdrummer 2 standalone and select the Yamaha E-drums MIDI mapping, does it work as expected?

    If it does, it is likely some setting inside Studio One that is causing it. If it doesn’t, we’ll think of something else.

    BR,
    John

    John Rammelt - Toontrack
    Technical Advisor

    dmarks
    Participant

    John Rammel, thanks for your response.  I have been corresponding via email to Toontrack and just saw this.  You are correct.  When using EZD2 standalone Ap, I don’t have the issue of the hi-hat staying open.  It is only when loading EZD2 as an instrument in Studio One Artist 5.  So, as you point out, it may be a setting inside Studio One.  Any suggestions on what this setting is and how to address it?  I would imagine your programmers work with Studio One and maybe they have an idea?

    khall187
    Participant

    Just chiming in that I have the same issue.

    Hihat works in Superior Drummer 3 stand alone

    Hihat doesn’t work in the DAW (but the MIDI data is being sent, can be read in the MIDI Monitor as a “Controller Foot Controller”).

    SO FRUSTRATING!!!!

    • This post was modified 7 months, 2 weeks ago by khall187.
    JohnJohn
    Moderator

    Hi guys,

    (sorry dmarks, I somehow missed your reply) isn’t there a MIDI Input Filter thing in Studio One?

    Also, you are using the same E-drums MIDI Preset in Studio One as you are using in the Standalone, right?

    BR,
    John

    John Rammelt - Toontrack
    Technical Advisor

    Anthony Neves
    Participant

    I noticed that the MIDI note that my Roland kit is putting out cc4 for the foot controller and a note of 8.  If I use the Midi Drum notes in my Roland Piano it expects a note of 62 for a tight edge.  Has this issue been fixed?

    Josh Korr
    Participant

    I am having this problem with my Roland TD-27 going into protools and standalone (12.7). I have selected “Roland” as the edrums. Please help!

Viewing 13 replies - 1 through 13 (of 13 total)

Please log in to read and reply to this topic.

×