EZMix 2 Latency Issue – Trying To Record While Hearing Guitar Amp

Requests and Feedback
Viewing 11 replies - 1 through 11 (of 11 total)
  • onewayout_1
    Participant

    I run reaper too…Just a thought…. Do you have a mix knob ratio on the Scarlett that would help? or do you have any other FX on the channel or MST channel?

    jeff

    callahan09
    Participant

    @onewayout_1 said:
    I run reaper too…Just a thought…. Do you have a mix knob ratio on the Scarlett that would help? or do you have any other FX on the channel or MST channel?

    jeff  

    Well, I tried it with the mix knob on the Scarlett in different positions. All the way to the left, I hear the clean guitar with no latency. All the way to the right I hear the effected guitar with tons of latency. In the middle, I hear both, but the latency between the two signals (the clean is not delayed, but the effected is) is too distracting to play through. So I pretty much just play it with the mix all the way left so I only hear the clean input signal when playing.

    There are no other FX on any channels, just clean guitar straight into the Scarlett, and the one EZMix plug-in on the recording track.

    Allen Ray
    Participant

    I’m having the same problem on a PC running Windows 10 64 bit. I use REAPER for my DAW as well. My interface is M-AUDIO M-TRACK. Tons of latency – it’s unusable at any of the latency settings I’ve tried.

    Dany Roy-Robert
    Participant

    Any solution about this problem ? I have exactly de same. 121.5 ms output latency when not used in a daw. That’s to much ! In cubase, no problem at all. Thank you.

    John
    Moderator

    Make sure you have reviewed the settings of your audio hardware outside of EZmix2. I.e. something like a separate ‘control panel’ for your hardware with buffer settings and sample rate, etc.
    On my hardware I have a I/O roundtrip latency of 23,2 ms @44,1kHz when running through EZmix2 standalone.

    BR,
    John

    John Rammelt - Toontrack
    Technical Advisor

    FiDProgsik
    Participant

    Hey guys

    I’ve changed my under settings/audio setup the audio device into ASIO and then i clicked on ASIO to change the buffer size to 64 or lower.

     

    DV81
    Participant

    just downloaded the demo …. sound is average and the delay between playing and what you hear is totally unusable.

    No online help or quick fixes ….. A bit disappointed as I heard this was the bomb…..

     

    John
    Moderator

    @DV81: If you are experiencing high latency, it most likely due to your audio hardware drivers. Please do not use a generic driver like e.g. ASIO4ALL, since it isn’t suitable for live tracking/playing.
    If you are using EZmix2 for electric guitar, please make sure you are using one of the presets with Amps.

     

    BR,
    John

    John Rammelt - Toontrack
    Technical Advisor

    Downzy
    Participant

    John, can you recommend an audio driver? I am using ASIO4ALL as well and experiencing the same issues.. please recommend?

    Rivrav7
    Participant

    Ex mix blows hard, latency issues as I see in these  post, spent too much money for it to have issues. Of course the fixes people suggest do not work. Great idea but biggest scam in the world. Definitely not worth $300+ dollars I spent on it. I have a pretty decent computer too. What I am finding frustrating even more is you buy the audio interface which is most likely the problem, not the software. But you buy software, audio interface than you need some sort Daw, always something, next I will need to buy something else to run DAW. I recently bought EZ drummer 2, and Ableton live, and what I freakin mess, nothing EZ about it. It so confusing on how to connect the to for recording, I figured it out eventually but, hey next make things a little more easier for setup. Like EZdrummer should have immediate setup instructions on how to connect the two. Looks like EZmix will not be part of my recording sessions, will go back to old school recording.

    Brianbcb
    Participant

    I solved the latency issue. I am using EZMIX2 in stand alone right now. I went to “Settings” “Audio Setup” and selected ASIO as the “Device type” and for “ASIO device” I selected the name of my interface which is a Scarlett Solo 1st Gen. I tried sample rate of 44100 and 48000 with buffer size of 256 and both work. I lowered the buffer to 16 and still works well. This EZMIX2 appears to be an excellent product.

    • This post was modified 2 months ago by Brianbcb.
Viewing 11 replies - 1 through 11 (of 11 total)

Please log in to read and reply to this topic.

×