icon-toontrack-20tt-20-symbolicon-aiicon-arrangementsicon-arrow-left-1icon-arrow-left-2icon-arrow-left-3icon-arrow-right-1icon-arrow-right-2icon-arrow-right-3icon-automationicon-bleedicon-bounceicon-brushesicon-brushes2icon-campaign-pageicon-circlesClosedicon-cloudCommentsicon-cross-invicon-crossicon-cymbalicon-dislike-1icon-dislike-2Unread topicicon-downloaddrumsicon-drag-dropicon-drumkiticon-drums2icon-drumsticksicon-edrumsicon-electronicTopicicon-envelopeicon-fadersicon-faqForumForumTopic replyicon-futurehiticon-galaxyicon-grid-editoricon-headphonesicon-hihaticon-hot-topicicon-importsamplesicon-information-invicon-informationicon-joystickicon-kickicon-like-1icon-like-2Locked topicicon-macrosicon-massenburgAccountCartSearchicon-microphoneicon-midi-exporticon-midi-searchicon-midi-trackericon-midi-tracksicon-midiicon-mix-channelsicon-mixericon-news-inspirationicon-one-noteicon-percussionicon-percussion2Sticky topicicon-play-1-invicon-play-1icon-play-2-invicon-play-2icon-play-3icon-plus-invicon-plusicon-presetsPrivate topicicon-rawicon-reverseanythingicon-samplesicon-save-drumicon-seamlessicon-settingsicon-shapesicon-snareicon-song-tracksicon-ssdicon-stackicon-tap2findicon-tempoicon-third-partyicon-three-notesicon-tomTopic with best answericon-two-notesicon-usericon-videoicon-workflow

EZ Drummer Demo Version latency

Requests and Feedback
Viewing 12 replies - 1 through 12 (of 12 total)
  • mgrossi
    Participant

    Having the same experience on 2017 15″ MacBook Pro Quad 16GB RAM.

    lgghita
    Participant

    I am having the same issue with the full version. In Logic Pro X using the integrated graphics the Tap to Find is jerky. Also the CPU usage on one thread runs very high (75-80%) and occasionally goes to 100% causing pops and cracks. When switching to the discrete graphics (Radeon 560X) the CPU usage goes down and the lag is gone. This only happens when I open the plugin, so the drums are displayed. If I close the plugin the CPU usage comes down, which leads me to believe that the issue is with the drum rendering optimisation. The drum graphics do not look like super eye candy, so I would not expect that you would need too much GPU power. Unless somebody argues differently, I believe the issue is code optimisation. I am running this on latest gen Macbook Pro 15″ with i9 8-core CPU and 16GB of RAM.

    ScottScott
    Moderator

    I am having the same issue with the full version. In Logic Pro X using the integrated graphics the Tap to Find is jerky. Also the CPU usage on one thread runs very high (75-80%) and occasionally goes to 100% causing pops and cracks. When switching to the discrete graphics (Radeon 560X) the CPU usage goes down and the lag is gone. This only happens when I open the plugin, so the drums are displayed. If I close the plugin the CPU usage comes down, which leads me to believe that the issue is with the drum rendering optimisation. The drum graphics do not look like super eye candy, so I would not expect that you would need too much GPU power. Unless somebody argues differently, I believe the issue is code optimisation. I am running this on latest gen Macbook Pro 15″ with i9 8-core CPU and 16GB of RAM.

    What latency are you running your audio buffer at? Lower buffer equals lower latency but higher cpu usage.

    Scott Sibley - Toontrack
    Technical Advisor

    lgghita
    Participant

    I am running at 128 samples. But the issue is not CPU usage during live playing. It only starts to be an issue when I open the EZdrummer GUI and the drums are diplayed. If the GUI is closed the CPU usage is half – there is only one thread that seems to handle EZD2. Hope this makes it clearer. Thank you.

    ScottScott
    Moderator

    I am running at 128 samples. But the issue is not CPU usage during live playing. It only starts to be an issue when I open the EZdrummer GUI and the drums are diplayed. If the GUI is closed the CPU usage is half – there is only one thread that seems to handle EZD2. Hope this makes it clearer. Thank you.

    I’ll have to hope a Mac user will chime in. On my Windows 7 and 8 machines with standalone, Cubase 9.5 and Reaper, I’m not experiencing and graphic issues.

    Scott Sibley - Toontrack
    Technical Advisor

    nicoamayab
    Participant

    I recently moved from PC to an iMac and I have been using ez drummer on my PC with no trouble… Now on my 2019 iMac

    iMac (Retina 5K, 27-inch, 2019) – processor 3 GHz 6-Core Intel Core i5 – 40 GB 2667 MHz DDR4 – Radeon Pro 570X 4 GB

    It is not the same… Tap to find is almost impossible to use… I have tested my drive speed and it is really high for write and read… every other software works great… Logic Pro X and FCPX…  I love EZ Drummer but now I am starting to not want to use it… Any ideas on how to resolve this?

    Thanks!

    JohnJohn
    Moderator

    Hi, could you please try to change the Colour Profile in the Display Preferences to ‘sRGB IEC61966-2.1’ then start EZdrummer 2 and try again?

    BR,
    John

    John Rammelt - Toontrack
    Technical Advisor

    1

    Thanked by: maxlemire
    nicoamayab
    Participant

    Hey John, thank you very much! I tried it and it’s not as smooth as on the PC but it improved a ton… At least now I can tap to find with the mouse more accurately! Greatly appreciate it because I was getting very disenchanted with EZ Drummer… The love is back.. I just finished a track and I am happy!

    Cheers!

     

    Nic

    hrolf1713
    Participant

    I have exactly the same issue. It worked like a charm some years ago but for some time now, when using EZdrummer as VST, everything works when it’s closed, but as soon as I open EZdrummer, everything becomes laggy as hell.

    Basically, when there’s nothing happening in EZdrummer (closed or not playing), it’s normal. As soon as it’s open and something is playing, it’s barely usable. It means it’s impossible, for example, to change elements on the drums while playing to have any kind of “real time” elements swapping. I have to stop the daw, change the elements I want to change, and then start again. No need to say the tap to find function is completely unusable. Same thing is happening with the standalone version.

    I’m on MacOS Mojave 10.14.6, but the issue is present for quite some time now, so it was also present when on High Sierra (maybe even on Sierra). Changing the color profile didn’t work for me.

    lgghita
    Participant

    Do have a discrete gfx chip as well? For me, with the Radeon chip it was working fine – but the system was running hotter and eating batter faster. Changing the color space solved it for the integrated Intel gfx chip as well.

    hrolf1713
    Participant

    No, it’s an integrated Intel Iris GPU.

    But the issue I face seems very similar to yours. I also sometimes have pops and crackles and what seems to be an overloaded CPU when EZD is open (even if when closed, my computer can handle dozens and dozens of plugins in real-time).

    Though, for me, changing the color profiles did absolutely nothing.

    Thinking about color profiles, I have a 4k monitor wired via a dock. Tomorrow I’ll also try to see what happens when opening EZD without that monitor attached and see if it changes something.

    hrolf1713
    Participant

    Ok so I can confirm not having the 4k monitor connected doesn’t change anything, even when disconnecting the whole dock, no soundcard, no nothing. Color profiles doesn’t change anything for me. That’s a mess.

    You can clearly see what happens in Reaper when opening EZD here (in this example, the track where EZD is in is the only one who has objects, every other track is either empty or muted; In Reaper language, that means every other track use aprox. 0% CPU):

    View post on imgur.com

    It may be a bit difficult to figure out without sound, but when in Tap2Find mode, there’s literally a 2 seconds delay between when I click with the mouse and when something happens in EZD. The same thing happens in standalone mode.

Viewing 12 replies - 1 through 12 (of 12 total)
×