Avatar

Please register or login to post.

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_TopicIcon
YAMAHA DTX700 WITH SUPERIOR - KICK PAD SENSITIVITY ISSUES
November 21, 2016
11:00 am CEST
Avatar
Adam Stanley
Watford, UK
Member
Forum Posts: 6
Member Since:
September 13, 2016
sp_UserOfflineSmall Offline

Hi all

I'm having sensitivity issues with my e-kit and Superior. The kick in particular doesn't respond well to anything other than hard hits. It picks up all my notes, but anything other than really big hits are registered with very low velocity, prompting a load of editing.

Also, I can't play with my normal finesse because I'm overcompensating for how hard I have to strike each surface.

Any tips for a noob would be much appreciated - I'm trying to go for good takes rather than editing the heck out of my songs so that I don't sound like a rank amateur!

Thank you.

November 21, 2016
6:50 pm CEST
Avatar
John
Sweden
Admin
Forum Posts: 7795
Member Since:
June 18, 2004
sp_UserOnlineSmall Online

Hi,

please try tweaking the Velocity Curve on the Mapping page.

S2-VelCurve.pngImage Enlarger

BR,
John

sp_PlupAttachments Attachments

January 4, 2017
12:36 am CEST
Avatar
stevenp_1
New Member
Forum Posts: 1
Member Since:
January 4, 2017
sp_UserOfflineSmall Offline

Adam Stanley said
Hi all

I'm having sensitivity issues with my e-kit and Superior. The kick in particular doesn't respond well to anything other than hard hits. It picks up all my notes, but anything other than really big hits are registered with very low velocity, prompting a load of editing.

Also, I can't play with my normal finesse because I'm overcompensating for how hard I have to strike each surface.

Any tips for a noob would be much appreciated - I'm trying to go for good takes rather than editing the heck out of my songs so that I don't sound like a rank amateur!

Thank you.  

Had this same problem with my new DTX760 kit with the KP100. It was all fixed by upgrading the firmware to v1.10. The new firmware has a startup that lets you selectthe proper kit for pad settings. I think the default on the old firmware is for the KP65 kick pad, which seems to be mroe sensitive, etc.

Forum Timezone: Europe/Stockholm

Most Users Ever Online: 715

Currently Online: John, Stevie Greer, Andreas, spohlso, stef_13
1 Guest(s)

Currently Browsing this Page:
1 Guest(s)

×