Avatar

Please register or login to post.

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_TopicIcon
MIDI Learn not working for cymbals with TD50
April 9, 2017
1:00 am CEST
Avatar
pimenta10
Member
Forum Posts: 5
Member Since:
January 1, 2007
sp_UserOfflineSmall Offline

Having problems with my TD50 and Superior.

Tried in both Solo and as a VST in Reaper. The MIDI learn function simply does not work for cymbals.

Kick/ snare and toms work fine. Click on the instrument, press learn, hit the pad.

It does not happen to the cymbals. They are stuck with whatever is set in Superior. I tried different Expansions and packs.... same thing.

Let me explain: in any of the packs that I have I load the kit, when when trying to use the MIDI learn in both Mapping page or Construct page ,
Superior completely disregard and stick with the original note of whatever Mapping is on the Preset.Even removing the note will not help.

For example on Avatar: Crash 1 on my TD50 (note 55 G 3) is stuck at Cymbal 3 slot on Superior. I want it to be Cymbal 1 (a China).

I go to Cymbal 1 - it is Blue because I selected it.. press Learn.. hit the pad... nothing. It is stuck at Cymbal 3. Even if I remove completely Cymbal 3... it is still mapped to my crash. It is so weird - even looking at the keyboard at the bottom of Superior Drummer, I see the note when I hit the pad as a different one from the cymbal in the Superior Kit (they light up in orange .. two different and distant keys....)

I have checked the TD50 MIDI setting _ go to KIT page.. press F5 and you see the MIDI notes being sent ... gate,MIDI channel. set to Global.

I even tried clearing the MIDI notes in the presets to start from scratch ... nothing....

Any clues??? What am I doing wrong??

Pim

Roland TD50
Roland Studio Capture
Reaper
Dell XPS i7 16gb RAM

April 9, 2017
2:12 am CEST
Avatar
juicy
Member
Forum Posts: 1156
Member Since:
April 4, 2005
sp_UserOfflineSmall Offline

I could be wrong but found if i selected the cymbal and and/or specific articulation in construct and then moved to the mapping window to check the specific or all articulations chosen (Very important to results ) and then did the learn on the mapping page it would stick. ymmv
Also the scripting in SD2 does some auto sharing of to next cymbal and stuff i can't explain very well but I'm sure you would be aware of that coming into the results

April 16, 2017
4:13 am CEST
Avatar
pimenta10
Member
Forum Posts: 5
Member Since:
January 1, 2007
sp_UserOfflineSmall Offline

Guys... any help at all? Problem persists.

Is this really Toontracks support forum for registered users??

Pim

Roland TD50
Roland Studio Capture
Reaper
Dell XPS i7 16gb RAM

April 19, 2017
4:03 am CEST
Avatar
pimenta10
Member
Forum Posts: 5
Member Since:
January 1, 2007
sp_UserOfflineSmall Offline

Is it a known bug???

Pim

Roland TD50
Roland Studio Capture
Reaper
Dell XPS i7 16gb RAM

April 19, 2017
8:51 am CEST
Avatar
Damian Blunt
Admin
Forum Posts: 2924
Member Since:
April 8, 2004
sp_UserOfflineSmall Offline

I've just checked and MIDI learn is working fine for cymbals here on the TD-20. Have you tried using learn on both the bow and edge of the cymbal? Do you have all cymbals loaded when you try MIDI learn? as Juicy said there is a substitution scheme for unloaded cymbals in the libraries which could be at play

The only other thing I can think of is if the TD-50 is sending some other MIDI information before the note is received by Superior 2 which could cause problems. I know Roland are using new technology for the cymbals with the TD-50

April 20, 2017
1:10 am CEST
Avatar
mikearmenta
New Member
Forum Posts: 1
Member Since:
October 1, 2008
sp_UserOfflineSmall Offline

Same here as Pimenta10! TD50K ok Superior won't change and no way I can fix the cymbals, after recording, a major deal to fix note by note, as you can see here it didn't look well with my clients that the sound was not up to par very disappointing to say the least I am with Pimenta10. Don't know if is superior OR TD50K but I think you guys at Toontrack need to test on a TD50K instead an old model like TD20!

April 21, 2017
11:19 am CEST
Avatar
pimenta10
Member
Forum Posts: 5
Member Since:
January 1, 2007
sp_UserOfflineSmall Offline

TIs it a known bug???

Pim

Damian Blunt said
I've just checked and MIDI learn is working fine for cymbals here on the TD-20. Have you tried using learn on both the bow and edge of the cymbal? Do you have all cymbals loaded when you try MIDI learn? as Juicy said there is a substitution scheme for unloaded cymbals in the libraries which could be at play

The only other thing I can think of is if the TD-50 is sending some other MIDI information before the note is received by Superior 2 which could cause problems. I know Roland are using new technology for the cymbals with the TD-50  

Thanks Damian for taking the time.

I tried using MIDI learn for the different articulations ... does not change at all.

The new digital technology is just for the Ride cymbal though.

Sorry but testing with the TD20 will not help.... i had a td20.... td30..... and worked fine.

Oops.. will update my sig

Pim

Roland TD50
Roland Studio Capture
Reaper
Dell XPS i7 16gb RAM

April 29, 2017
12:50 pm CEST
Avatar
pimenta10
Member
Forum Posts: 5
Member Since:
January 1, 2007
sp_UserOfflineSmall Offline

Roland TD50
Roland Studio Capture
Reaper
Dell XPS i7 16gb RAM

May 9, 2017
10:31 am CEST
Avatar
Mika_14
Member
Forum Posts: 5
Member Since:
April 13, 2017
sp_UserOfflineSmall Offline

Vdrums.com is goo d forum. Here there is zero support. I regret very much to have invest in toontrack 's product.

May 9, 2017
2:03 pm CEST
Avatar
John
Sweden
Admin
Forum Posts: 7751
Member Since:
June 18, 2004
sp_UserOfflineSmall Offline

Hi Mika_14,

please remember that this section of the Forum is User/Community driven.
If you need specific product support, there are Help sections for each product in the registered users area, where your posts will monitored by Technical advisors as myself.
You can also contact Toontrack Support directly by going to:
http://www.toontrack.com/faq/m.....what-next/
and click 'Contact Support'. Well, every FAQ actually has the 'Contact Support' button at the bottom of the page.

BR,
John

May 9, 2017
3:35 pm CEST
Avatar
Mika_14
Member
Forum Posts: 5
Member Since:
April 13, 2017
sp_UserOfflineSmall Offline

This explain that. I didn't understand "community" in this way (english is not my 1st langage).

Forum Timezone: Europe/Stockholm

Most Users Ever Online: 715

Currently Online: Wallplug, Fimmel Ronny
30 Guest(s)

Currently Browsing this Page:
1 Guest(s)

×